How can we help you?


We know that getting support quickly is important, therefore you can contact our support around the clock. Our ambition is to get back to you within two hours Monday to Friday 9-17 or at the latest the following workday.

+4618-432 03 00

FAQ Royal Play

  1. There´s no sound coming through the speakers
    1. 1. Make sure that the sound cable is connected both to the device and to the amplifier.

      2. Check that you have selected the same labeled port on the front of the amplifier as the one you connected your cables to on the back. (The most common one is the AUX port.)

      3. Check the volume level on the device you are playing from (Tablet, Smart Phone or Computer) and make sure you haven’t muted it.

      4. Try playing the stream through the device’s internal speaker. If the internal speaker works, the issue is probably related to either the sound cable or your amplifier. Please contact the person in charge of IT in your store for further assistance.

  2. The music is “choppy”, i.e. stopping and starting
    1. First check the Amplifier:

      This issue can be due to lack of constant 0.5 Mbit/s bandwidth or other network setting issues.
      As this is a network related problem, please contact the person in charge of IT in your store. Before you do, please check the following:

      1. Make sure that your device (Tablet, Smart Phone, Computer) is connected to the proper Network / Wi-Fi.

      2. If your device is connected to Wi-Fi, please check that it isn’t shared with a Guest Wi-Fi.

      3. Make sure someone isn’t using the Network for unintended purposes, i.e. downloading, etc.

      Still having problems? Please contact the person in charge of IT in your store for further assistance.

  3. Is your problem related to none of the above?
    1. Please contact our support at:
      Email: [email protected]
      Tel: +46 (0)18 – 43 20 300

FAQ Streamit Box

  1. The music is very repetitive
    1. The box is most likely playing from it’s memory card instead of the stream. If the bottom row on the display says “1.pls” press the button labeled “ALT”. Your channel name should then appear on the bottom row instead of “1.pls”. If nothing happens, please visit the section below called:
      “The display says: [Reconnecting in X seconds…] and [1.pls].”

  2. The music is “choppy”, i.e. stopping and starting
    1. This can be due to lack of constant 0.5 Mbit/s bandwidth or other network setting issues. As this is a network related problem, contact the person in charge of IT in your store. Before you do, please check the following:

      1. Make sure that the box is connected to the proper network.

      2. Make sure someone isn’t using the internet for uninteded purposes, i.e. downloading, etc.

      Still having problems? Please contact the person in charge of your IT in your store for further assistance.

       

  3. The box won´t start
      1. 1. Make sure the Power Cable is plugged in to both the box and a Power Outlet.
      2. 2. If it is, try another Power Outlet.
      3. 3. If that doesn’t work, please contact us for replacement of the box.
  4. There is no sound coming through the speakers
      1. 1. Make sure that the sound cable is connected both to the box and to the amplifier. Also check that the volume knob isn’t turned down too low.
      2. 2. Check that you have selected the same labeled port on the front of the amplifier as the one you connected your cables to on the back. (The most common one is the AUX port.)

      3. Press the right arrow on the box to make sure it plays at its max volume, the max volume is 31.

      Still no sound? Please contact our support at:
      Email: [email protected]
      Tel: +46 (0)18-43 20 300

  5. The display says: [Reconnecting in X seconds…] and [1.pls]
    1. This means that the box can’t connect to the internet. Please follow the steps below:

      1. 1. First check that the network cable is connected to both the box and your router/switch/modem.
      2. 2. Try to restart the box with the ON/OFF-button.
      3. 3. When the box is on, check the Ethernet LED lights on the back of the box. If the lights aren’t lit, try with a different network cable.
      4. If none of the above works, please contact the person in charge of your IT in your store for further assistance.
  6. Is your problem related to none of the above?
    1. Please contact our support at:

      E-mail: [email protected]
      Telephone: +46 (0)18 – 43 20 300


Still not solved?


Contact us
+46 18 432 03 00 E-mail